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1 Introduction

MS Project has been especially developed for project management and is a useful software application for planning, tracking and controlling a project.

What can MS Project do for you?
· MS Project is only a tool which supports project managers. It does not execute project management for you. 

· MS Project can do calculations in terms of durations or costs accurately.
· MS Project allows ‘what if scenarios?’, to make changes to the project and see the effects to those changes before finalising your plan and committing it to work.

· Once your plan is in action, MS Project can track all the information you collect about the work, duration, costs and resource requirements for your project so that you can make adjustments in order to keep on target.
· MS Project helps you to create and print various predefined reports and views quickly.
Hovever, which ever project management software package you have in use, the machine cannot do four things:

· It cannot create the tasks for you

· It cannot create the logical relationships between the tasks
· It does not know the duration of tasks 
· It cannot possibly know what resources you have to apply to the tasks

Thus the drawing up of a detailed work plan showing the logic of sequences is an essential part of the planning process. 
NOTE: MS Project also has a very useful Help facility with its own set of online tutorials that you can do at any time.
2 Working with MS Project

2.1 Starting MS Project

Programs > MSOffice > MS Project
A screen similar to the one below should appear:
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2.2 The MS Project 2003 workspace:
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Working Area of the Screen
The main working area of the screen is split in two main parts: the Entry table on the left and the Gantt chart [named after the U.S. engineer H. L. Gantt] on the right, separated by a divider bar.

Entry Table
The entry table will contain a listing of every task required by the project and will show calculated details for each task.

Gantt Chart
The Gantt chart will show bars drawn to represent the duration of each task against a calendar timescale.
The name of the active view appears on the left edge of the view
3 Creating a new Project

Before you can put any information into the computer you have to plan the project in some detail:
· Produce a work breakdown structure with a task list
· Produce a time schedule (sequencing and linking of tasks)
· Produce a resource plan (people, material, budget required)
· Assign resources to tasks

	Tasks are the basic work units of a project and describe project work in terms of sequence, duration, and resource requirements. 


3.1 Setting the project start date and adjusting the project calendar:

Projects can be scheduled from the start date or backwards from the end date. 

Set the start/end date as well as the schedule form in the Project Information Pane; to access this dialog box click on ‘Project’ in the main menu bar and select ‘Project Information …’
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For changing the working times of the Standard Calender (Mo – Fri, 8-12 and 13-17) click on ‘Tools’ in the main menu bar and select ‘Change Working Times …’

[image: image4.png]] Fle Edt Vew Inset Fomat Took Project Colaborate Window Help
DEHBISAT 8B S8 =588 L8 |3 Newr RQAFBO

eI
: 3 |[fols] | Resources .\na(k < repn - b

Change Working Time (%) mRETER 5 Nov 05

WL [T [F S ]S M T [W[T[F
Fori [Stonderd (Project Calendar)

et working time for selected date(s)
Legend: Select Date(s) Set selected date(s) ot

October 2006 & Use defaul
[0 wlTh]F

| Working
v © borwerking time

Nonworking € Nondefaul working time.

" Edted working Erom: o
 hours 500

On this calendr

(2

7] Edtstoaday of

the wesk

T Edtstoan
 individual day

Options.





3.2 Adjusting the Time Scale Format

In order to change the format of the time scale for the Gantt-Chart select ‘Format’ in the main menu bar and click on ‘Timescale …’
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3.3 Enter Task Names and Task Roll Ups
1) If the task table is not already displayed then click ‘Tasks’ on the toolbar

2) Click the cell directly below the Task Name column heading

3) Type in the task name and press ENTER

Your screen should now look similar to the one below.
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Each task gets an ID number. Each task has a unique ID number, but it does not necessarily represent the order in which the tasks occur.

You will notice that the duration defaults to 1 day with a question mark – this indicates that this is an estimated duration you can change later.
A corresponding task bar of one day’s length appears in the Gantt chart. By default the task start date is the same as the project start date.
3.4 Organising Tasks into Phases:
A summary task, or a roll up, consists of a number of sub-tasks.  In the Gantt Chart a summary task is indicated by the summary task bar and the summary task name appears in bold letters. 

To allocate an individual task to a summary task you have to indent the task. You can indent or outdent a task by selecting the task and clicking on the indent or outdent icon in the tool bar.
3.4.1 Estimating Durations:
The question mark in the duration field indicates that the duration is an estimate. The duration of a task is the amount of time you expect it will take to complete the task. The durations can range from minutes to months. But most commonly used are hours, days, and weeks. 

Project task durations differ from calendar durations. For instance if you schedule an 8 hours working day and you have a task that takes 16 hours, you could enter its duration as 2 days to schedule the work. However, if you schedule the start of the task for Friday 8 am it would not be completed before Monday 5 pm, because Saturday and Sunday (by default) are scheduled as nonworking time. But of course it is possible to set the weekend as working time. 

Milestones: If you enter 0 for the duration of a task the blue bar becomes a black diamond with a date – this is called a Milestone and denotes an important decision or action point in a project.

After you have entered task durations your project plan should now look similar to the one below:
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3.4.2 Linking Tasks

A powerful way of sequencing tasks is to define the predecessor task(s) for each task. 
You can select the preceding tasks in the task information pane. In order to display the task information pane for a specific task, select the task, and either double-click on it or click on the right mouse button and select Task information …
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You will need to go to View > Zoom > Entire Project periodically to keep your project plan in view.

3.4.3 Displaying the project summary task

1) MS Project automatically generates the project summary task but doesn’t display it by default.

2)  Click on Tools in the main menu bar and select Options
3) Select the View pane
4) Under ‘Outline options for …’  select the Show project summary task check box, and then click OK

5) MS Project displays the project summary task at the top of the Gantt chart view. 
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3.4.4 Show Outline Number: (WBS Code)

Tools > Options > View > Show outline number
4 Adjusting Task Relationships:

There are 4 types of task dependencies:

Finish to start: finish date of predecessor determines the start date of the successor

[image: image10.emf]
Example: the walls of a house must be erected before you can put on the roof.

Start to start: start date of predecessor determines the start date of the successor.

[image: image11.emf]
Example: library research and web research are closely related and can occur simultaneously.

Finish to finish: finish date of the predecessor determines the finish date of the successor

[image: image12.emf]
Example: cooking a turkey and potatoes for a dinner. Both dishes need to be ready at the same time, independently from their individual cooking times.

Start to finish: start date of the predecessor determines the finish date of the successor task. This relationship is very rarely used.
[image: image13.emf]
Example: You need a lot of printing paper in your project but don't have room on your office for a great number of paper boxes, so you only order new printing paper when your supply is running low. The depletion of paper by current activities triggers an order for more paper. 

· Task relationships reflect the sequence in which work should be done. 

· By default MS Project uses Start to finish relationships. 

· In order to change the task relationship type double click on the task and select the Predecessor window in the task information pane:
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You can also schedule:

· An overlap (called lead time) OR

· A delay (called lag time)

between the finish and start dates of predecessor and successor tasks.

If 2 tasks have a FS-relationship:

· Lead time causes the successor task to begin before its predecessor task concludes

· Lag time causes the successor task to begin some time after its predecessor task concludes.

4.1 Task Constraints:

There are 3 categories of constraints:

· Flexible constraints

· Semi-flexible constraints

· Inflexible constraints

Setting task constraints:

1) Double-click on a task in order to open the ‘Task Information’ window

2) Select ‘Advanced’

3) You can set a Deadline for this task OR

4) You can choose from a list of constraint types and specify a constraint date.
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4.1.1 Flexible task constraints:

Flexible constraints allow tasks to be scheduled without any limitations other than their predecessor and successor relationships. 

No fixed start or end dates are imposed by the constraint types. 

Use these constraint types whenever possible!

ASAP (as soon as possible):

This is the default setting in project when scheduling the project from the start date. If you do not change this constraint, all tasks will occur as soon as they can occur.

ALAP (as late as possible): 

Project will schedule all tasks as late as they can occur. This is the default setting in project when scheduling the project from the end date. 

4.1.2 Semi-flexible constraints:

Limit the rescheduling of a task within the date constraints you specify. 

SNET (start no earlier than):

Use this constraint to ensure that a task will not start before a specific date.

SNLT (start no later than):

Use this constraint to ensure that a task will not start after a specific date.

FNET (finish not earlier than):

Use this constraint to ensure that a task will not finish before a specific date.

FNLT (finish not later than):

Use this constraint to ensure that a task will not finish after a specific date.

4.1.3 Inflexible time constraints:

Completely prevent the rescheduling of a task. Use these constraint types only when absolutely necessary!

MSO (must start on): 

Use this constraint to ensure that a task will start on an exact date.

MFO (must finish on):

Use this constraint to ensure that a task will finish on an exact date.

Use inflexible constraints only if the start or the finish date of a task is fixed by factors beyond your control. 

“Work”, and “Duration” are both measured by time, but “Duration” is different from “Work”. For this reason, we use a different unit of time for duration. 

· Measure work in hours. It is multiplied by the hourly pay rate to calculate labour costs.

· Measure duration in days, or weeks, whatever suits the length of your project. 

As an example of why Work and Duration are different, consider these examples:

· Quotes are required from suppliers, and although we can send a covering letter with only 3 hours work, allowing the suppliers a 2 week response time might make the total duration 3 weeks.

4.2 Task Types:

There are 3 different task types:

· Fixed Duration

· Fixed Work

· Fixed Units

4.2.1 Fixed Duration
A task takes so long, no, matter how many resources are thrown at it. Paint drying, concrete setting, machine cycle times, are all examples.
4.2.2 Fixed Work
The amount of work is fixed, but the work will (nearly) half if we double the resources. Getting 2 gardeners to tidy a garden, or 2 painters to emulsion paint a room are good examples. 

After a certain point though, the resources start to argue, discuss, and run out of tools or other resources/materials. Normally there is a limited benefit from adding resources to a task.

4.2.3 Fixed Units
A set number of resources are required to do the task, e.g. student and supervisor in order to discuss the topic of the diploma thesis.

5 Project Resources

In a project we need resources – people, equipment, material – to complete the tasks. 

With MS Project we can control basically 2 aspects of resources: 

· Availability

· Costs

Availability determines when specific resources can work on tasks and how much work they can.

Costs refer to how much money will be required to pay for those resources.

There are 2 types of resources in MS Project:

· Work resources (people and equipment that do the work)

· Material resources

Examples:

· Individuals identified by name:


Claudia Lembach

· Individuals identified by job title / function: 
supervisor, interviewer

· Groups of people with common skills:

electricians, interviewers

· Equipment:





Camcorder, batteries

Equipment resources don’t need to be portable: a fixed location (e.g. for a photo shooting, video editing lab, printing house) can also be considered as equipment.

5.1 Entering resources into the Resource Sheet:

1) Click on ‘View’ in the main menu bar and select ‘Resource Sheet’

2) Click in the first cell underneath ‘Resource Name’ and type in the resource name and press ENTER

3) In the Type field, select either Work or Material. 

4) The Max. Units cell represents the maximum capacity of a resource to accomplish a task. Maximum capacity of 100% this means that 100% of this person’s time is available to work on a given tasks. 
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5.1.1 Setting Up Equipment Resources

You can set up people and equipment resources likewise. 

5.1.2 Setting up Material Resources

Material resources are consumables that you use up as the project proceeds. For instance material resources might include batteries, nails, concrete etc. 

5.1.3 Entering Resource Pay Rates

Tracking and managing cost information allows you to answer questions as:

· What is the expected total cost of the project, based on our task duration and resource estimates?

· Are we using expensive resources to do work that less expensive resources could do instead?

· How much money will a specific type of resource or task cost during the whole project life cycle?

· Are we spending money at a rate that we can sustain for the planned duration of the project?

In Resource Sheet, click the ‘Standard Rate’ field to enter pay rates for resources.

5.1.4 Documenting Resources:

1. Double-click on a resource and you will get a screen similar to the one below:

2. Please select the Generals Screen. You can put Email-Address, Specify type of work

3. Please select the Cost Screen. You can see the cost details we specified for our resource.

5.2 Adjust the Working Time for the Resources:

A resource calendar controls the working and nonworking times of a resource.  By default MS Project uses the Standard base calendar (Monday to Friday, 8 am to 5 pm)

If all the working times of your resource plan are the same as the Standard base calendar, you do not need to edit any resource calendars. 

However, it is very likely that your resources will need exceptions to the working time in the Standard Calendar, such as:

· A flexible work time schedule

· Vacation time

· Other times when a resource is not available to work on the project, such as time spent on training or attending a conference

This means, when you change the working time in the Standard Calendar, the changes apply to the timeframe of the whole project. 

Therefore, it is better to apply specific changes to the individual resources rather than to the Standard Calendar. 

For changing the individual working times click on ‘Working Times’ in the Resource Information pane.

6 Formatting and Printing the Project Plan

Views and reports are the most common ways to see or print a project plan’s data.

The default formatting of the Gantt Chart View works well for onscreen viewing, and printing. However, it is possible to change the formatting of just about any element on the Gantt-Chart.

3 ways of formatting a Gantt-Chart:

· Format whole categories of Gantt bars in the Bar Styles dialog box, which you can open by clicking in the Bar Styles command on the Format menu.

· Format whole categories of Gantt bars using the Gantt Chart Wizard, which you can start by clicking the Gant Chart Wizard command on the Format menu

· Format individual Gantt bars directly by double-clicking on the Gantt bar to get its formatting options.

6.1 Creating a copy of the Gantt Chart
6) Create a copy of the Gantt Chart view so that the formatting changes you make won’t affect the original Gantt Chart view.

7) On the VIEW menu, click More Views

8) Click the Copy button

9) In the Name Field type ‘Copy of Gantt Chart’ and then click OK

10)  In the More Views dialog box, click Apply. Now you have an exact copy of the original Gantt Chart view. Notice that the view title on the left edge of the view will be modified, too.

Using the Gantt Chart Wizard to format the Gantt bars and milestones in the chart.

1) On the FORMAT menu, click on Gantt Chart Wizard

2) Click Next, click the Other button, and in the drop-down list select for example Style 4

3) Click next and select ‘Resources and Dates’, click Next
4) Select ‘Links’ between tasks, click Next, and then ‘Format it’ and Exit Wizard
5) Select on the File menu, Print Preview and you can see how your project plan will look like if you print it out. 
6) You can likewise format text, Gantt bars, add Resource Initials instead of complete names etc.
7) Use Page Setup, on File menu in order to add additional information, e.g. page numbers, header or footer information etc.
7 Saving a Project Baseline

A baseline is a collection of important information in your project plan, such as the planned start dates, finish dates, and the costs of the tasks, resources, and assignments. When you save a baseline, MS Project takes a snapshot of the existing values and saves it in your project plan for future comparison.

Saving the project plan as a baseline

1) Make sure you have your project plan saved

2) On the main menu bar click on TOOLS > Tracking > Save Baseline …
3) Save as baseline

4) Project saves the baseline, even though there’s no indication in the Gantt Chart view that anything has changed.
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To view the changes caused by saving the baseline:

1) Click on VIEW in the main menu bar, and then select MORE VIEWS
2) Click TASK SHEET, and then APPLY
3) On the main menu bar click on VIEW again and point to TABLE: SUMMARY, and click Variance
4) The Variance table includes both the scheduled and the baseline start and finish columns, shown side by side for easy comparison
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8 Assigning Resources to Tasks:

Assignment = task + resource

Switch to the Gantt chart view in order to assign resources to tasks.

4 ways of assigning resources to a task 

1. Double-click on a task and assign the resources in the resource pane

2. Gantt view, select the task and click on the ‘Assign Resources’ icon in the tool bar

3. Click on ‘Tools’ in the main menu bar and select ‘Assign Resources’

4. Gantt view, split window and assign resources in the task form.

The assign resources dialog box appears. In it you can see the resources your can assign or you’ve already entered. 
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Assigning resources in the split window view:
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Recommended:

Use split window view in order to assign resources. MS Project can get very confusing when starting assigning resources to tasks due to task types settings and the so-called effort driven scheduling.

8.1 The Scheduling Formula: Duration, Units, and Work:
MS Project calculates work using the so-called scheduling formula:

Duration x Units = Work
In general, the amount of work will match the duration unless you assign more than one resource to a task or the one resource you assign is not working full-time.

Example:

Task 4 (Refine Plan) in our ‘Writing a Diploma Thesis’ project has a duration of 3 days. When you assigned a resource with max. units of 100% to task 4 the scheduling formula looks like this:

24 hours task duration x 100% assignment untis = 24 hours work

If the resource can only work e.g. 70% the work would be 16,8 hours.

On the other hand, if we assign to resources of 100% max. units to this task the works would increase to 48 hour – the 48 hours is the sum of either resource 24 hours of work. In other words, both resources will work on the task in parallel. 

8.2 Effort-driven scheduling method:
By default, MS Project uses a scheduling method called effort-driven scheduling.  This means that the task’s initial work value remains constant, regardless of the number of additional resources you assign. The most visible effect of effort-driven scheduling is that as you assign additional resources to a task, that task’s duration decreases or increases. 

Project applies effort-driven scheduling only when you assign resources to tasks or remove resources from tasks!

The task type determines which of the the three scheduling formula values remains fixed if the other two values change.

Fixed Units (default task type):

When you change a task’s duration, Project recalculates work. Likewise, if you change a task’s work, Project recalculates duration.

Fixed Duration:

You can change a task’s units or work value, and Project will recalculate the other value.

Fixed Work:

You can change the units or duration value, and Project will recalculate the other value.

Note that specifying a task as fixed does not mean its duration, units or work are unchangeable. You can change any value for any task type.

9 Tracking the project’s progress

Tracking means recording project details such as who did what work, when the work was done, and at what cost. These details are often called ‘actuals’.

Tracking actuals is essential to properly managing a project, as opposed to just planning, a project. 

Nevertheless, unless a task has been completed to 100% tracking work in progress is in many cases a ‘best guess’ effort and inherently risky!

Tracking project performance helps you to answer questions such as:

· Are task starting and finishing as planned, and, if not, what will be the impact on the project’s finishing date?

· Are resources spending more or less time than planned to complete tasks?

· Are higher-than-anticipated task cost driving up the overall cost of the project?

MS Project supports several ways to track progress. The tracking method you choose should depend on the level of detail or control required by you, your sponsor, and other stakeholders. Tracking the fine details of the project requires more work from you and possibly from the resources working on the project. 

9.1 Levels of tracking:

· Record project work as scheduled. Works best if everything in the projects occurs exactly as planned.

· Record each task’s percentage of completion, either a precise values or at increments such as 25, 50, 70, 75, or 100

· Record the actual start, actual finish, actual work, and actual and remaining duration for each task or assignment.

· Track assignment-level work by time period. This is the most detailed level of tracking. Here you record actual work values per day, week or another interval.

It is likely, that you might need to apply a combination of these approaches within a single project. 

9.1.1 Track a project as scheduled

The simplest approach to tracking a progress on you project is to report that the actual work is proceeding exactly a planned. 

E.g. if a certain period of time has elapsed and all of tasks have started and finished as scheduled, you can quickly record this in the Update Project dialog box

· Switch to Gantt Chart View
· On the Tools Menu, select Tracking and then Update Project
· The Update Project dialog box appears

· Select Update work as complete through and in the date list select the date until the tasks are completed.

MS Project records the completion percentage for the tasks. It also displays that progress by drawing progress bars in the Gantt bars for those tasks. Furthermore, check marks appear in the indicator column for tasks that have been completed. 

9.1.2 Entering a Tasks’s Completion Percentage

You can record each task’s percentage of completion, either at precise values or at increments such as 25, 50, 70, 75, or 100

1. Select the task you want to track
2. In the Main Menu bar click on Tracking and then Update Tasks

3. Enter the percentage of completion for the selected task

4. You can also enter the actual duration of a task as well as the actual start and finish dates. If you change the duration or the start and finish dates project will recalculate the start and finish times of the related tasks accordingly.

9.1.3 Tracking Actual Work for Tasks and Assignments

The most detailed way of recording actuals is to record the actual work accomplished by the assigned resources. 
1) Switch to the Task Usage View

2) Select the task you want to update in the data spreadsheet and the click on Go to selected task in the tool bar
3) On the View menu, point to Table: Usage, and then click Work
4) On the Format menu, point to Details, and the click Actual Work

For each task and assignment, Project displays the Work and the Actual Work rows

5) You can enter the actual work value for the resources in the respective cells.
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